Debian Wheezy PHP 升級至 PHP 5.6 版

Debian 作業系統 7.X 版(Wheezy) 與 8.X 版 (Jessie) 預設的 PHP 版本是 5.4.X 版,但是一些 PHP 的框架系統 (Frameworks) 通常要求至少要到 PHP 5.6 版。今天根據網路其他文章的參考,完成了 PHP 的升級,順便與大家分享。

文章原始網址:https://serverfault.com/questions/694385/how-to-upgrade-php-5-4-to-php-5-6-on-debian-gnu-linux-7-wheezy

步驟:

1.

echo “deb http://packages.dotdeb.org wheezy-php56 all” >> /etc/apt/sources.list.d/dotdeb.list
echo “deb-src http://packages.dotdeb.org wheezy-php56 all” >> /etc/apt/sources.list.d/dotdeb.list

2.

wget http://www.dotdeb.org/dotdeb.gpg -O- | apt-key add –

3.

apt-get update

4.

apt-get install php5-cli php5-fpm

(其他 PHP 模組會自動跟著更新)